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Introduction 

Flote is a software application for the high-throughput behavioral analysis. The main 
purpose of this utility is to take stacks of images of groups 5-8 day old zebrafish larvae 
recorded with high speed cameras and detect the initiation of discrete elements of the 
larval motor repertoire. 

In the process, Flote extracts a large amount of information about the kinematics of 
movement, which can also yield useful insights into behavioral modulation. Flote can 
also be used for the much simpler application of tracking larvae and measuring non-
kinematic features, like position, speed and orientation. 

The algorhythms underlying Flote are described in these two articles: 

Burgess HA and Granato M. (2007) Sensorimotor gating in larval zebrafish. J Neurosci. 
27:4984-94. 

Burgess HA and Granato M. (2007) Modulation of locomotor activity in larval zebrafish 
during light adaptation. J Exp Biol. 210:2526-39. 

Flote was written by Harold Burgess in the laboratory of Michael Granato at the 
University of Pennsylvania. Much thanks to John Crocker from the Department of 
Bioengineering for the particle identifying algorithm, Jeremy Magland for mathematical 
assistance and Hannah Shoch for extensive road-testing. 

Bugs, both known and obscure remain in the code. Please let us know if you find 
anything egregious. In addition these instructions are a work in progress, incomplete in 
some areas. 
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1. Installing the software 

1. 1. Installation 

Flote is written in the IDL programming language. To run Flote, you must have the IDL 
Virtual Machine installed on your computer. This is a free download, which (currently) 
may be obtained from: 

http://www.ittvis.com/download/download.asp?searchstring=&radDownloadType=Down 
load&ProductVersion=279&Platform=All+Platforms&DownloadType=All+Types&sub 
mit=Submit 

In case the address of the download site changes, search for 'ITT Visual Information 
Solutions' and find the link on their website for 'IDL VM'. Note that the IDL download is 
going to install two pieces of software on your computer (1) IDL itself which will operate 
in 'trial mode' for 7 minutes and (2) the free IDL runtime platform which will execute 
pre-compiled code. To use Flote you only need the runtime platform and therefore do not 
need to purchase IDL. 

In principle, the code should run under any platform for which an IDL Virtual Machine is 
available, however we have not attempted to use anything other than Windows 2000 and 
Windows XP. The minimum hardware we have used is 512MB RAM with a 2.8 GHz 
processor. 

Once you have installed the IDL Virtual Machine, make a directory for the three files, 
'flote.sav', 'flote_setup.sav' and 'batchan.sav'. Run the 'flote_setup.sav' file. Note if you 
have software like SPSS installed on your computer, you will need to right click on the 
flote_setup.sav file and open it with ' IDLRT'. This will create a folder: 'C:\ftrack\' with 
various subfolders, used for storing your settings and in some cases your output files. 

In addition, you need to specify three settings: 

1. The default video directory. This is where Flote will by default look for video files. 
2. The save tracks directory. This is where Flote will by default save tracking files. It is 
often advantageous to run Flote on multiple computers to speed up the tracking. If you 
intend to do this, make sure that the 'Save tracks' directory is accessible from all 
computers. The exact path to the directory should be specified. For example for a local 
directory it might be 'C:\Share\tracks' and while the path to the same directory from 
another computer might be 'S:\tracks' 
3. A computer identifier. This is only really important if you will use more than one 
computer for analyzing data. Each computer should have an name. 

When you have entered your settings, press the Save button then Quit. Alternatively, 
press Quit to leave the setup program without modifying the settings. 
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By default, when you open Flote, it displays 4 larvae in the middle of the screen. To 
change this, place a jpg image in the 'C:\ftrack\startim' directory. 

1. 2. Un/Re-installing 

To uninstall, just delete the directory 'C:\ftrack' and the Flote.sav files.
 

For a completely fresh install, delete the directory 'C:\ftrack' and the old Flote.sav files,
 
then run the flote_setup.sav again.
 

To upgrade to a newer release of Flote (and keep most of your saved configurations),
 
don't delete the C:\ftrack directory. The flote_setup.sav program will overwrite only your
 
Default configuration and default paths. This procedure is also useful for giving your
 
computer a new name, or changing the default video and tracks directories.
 
Occasionally, depending on the version you are upgrading from, this may not be
 
sufficient and you should then perform a fresh installation.
 

1. 3. Using the Folder Browser 
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1. Select the drive you want (or use the 'Tracks', 'Video' or 'User' presets to quickly 
navigate to the target folder) 

2. Navigate to the desired folder. Double click on a folder to enter it. If you enter a 
directory with a huge number of files, it can take a long time to enter the folder 
(especially if they are on a network drive) - avoid this! Double click on the '...' to go back 
up a directory. Single click on a folder to set it as the folder which will be selected. You 
can always see which folder is the one which will be selected, by the text beside the 
'Select' button. 

3. Press 'Select' to choose the folder beside the button. 

To cancel the operation, hit 'Cancel'. 

The 'Tracks' and 'Video' folders are the default folders for storing video and tracks 
specified during installation. A third preset 'User' is available. You can set this by 
pressing the '[Set]' button when you have choosen a desired folder. Occasionally you will 
have another option on the top right 'Store' - this sets the folder as the default for the 
current type of folder selection operation. 
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2. Recording Videos 

2. 1. Kinematic Analysis of Zebrafish Larvae 

Larvae should be recorded using a suitable lens so that their length is roughly 50 pixels. 
Flote will not work well unless the larvae are of about the same length. Older larvae 
(after about 10 dpf) are often variable in length, so either presort ones of about the same 
length or use younger larvae. 

The recording speed will depend on the application. However, for automatically 
identifying motor patterns, the software requires that the recording is made at exactly 
1000 frames per second (fps). We generally a resolution of 512x512. Videos should be 
saved as a stack of 8-bit (i.e. grayscale) JPEGs with 75% 'quality' compression. 
Lower quality compression (< 50%) leads to significant degradation in tracking. Higher 
quality compression (>90%) yields much larger file sizes resulting in reduced tracking 
speed and produces only marginal improvements in accuracy (less than 1% more 
'trackable' objects). 

Each video should be saved in its 
own folder and the names of the file 
stack should be the same as the 
folder name PLUS an underscore 
PLUS the frame number. The first 
frame should be numbered zero. 

Example: You recorded a 8000 
frame video, which contains 40 
events each of 200 frames. Make a 
folder called 'off_01a' and inside the 
folder, save the video as a stack of 
JPEGS where the first frame is 

called 'off_01a_0000.jpg' and the last frame is called 'off_01a_7999.jpg' 

If your recording software doesn't permit this naming convention, videos will still load, 
so long as the stack of frames are still in their own folder and in alphanumeric order. 
However image stacks will take longer to load. 

2. 2. XYA Analysis of Zebrafish Larvae 

Flote can operate in a simpler mode, in which only position and orientation information is 
analyzed. For this type of recording, it is still necessary to optimize centroid finding (see 
below), but not essential to optimize eye-finding or curvature. Resolution is not 
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important, so long as the position (and usually orientation) can be succesfully determined 
by Flote. 

2. 3. Other animals 

Flote can also perform simple tracking of other groups of animals, yielding position, 
speed and orientation information. Where displacement is a reliable measure of 
movement, it can also classify individuals as moving or stationary. For robust tracking, 
the recording frame-rate should be sufficient that individuals move less than half a body 
length between frames. For Drosophila, we find that 100 frames per second works well. 
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3. Setting object detection parameters 

3. 0. Loading Videos 

Choose: File→Select video directory then single click on a folder containing a stack of 
JPEGS. Click 'Select'. The first image in the stack should now be displayed and the 
message window will display 'First image in folder' and the dimensions. 

If there is an error, the message window may read 'No suitable jpegs in folder'. This 
usually reflects non-conformity of the filenames to the convention described in section 
2.1, but could also reflect an unusual mode of saving jpegs - remember they should be 
grayscale. There is a known bug in Flote - if you try selecting a new working directory, 
while the graphing window is open it will also generate an error. Just close the graph 
window and try again. 

For optimal loading, the first file should be numbered zero. However if the video 
directory contains a '.cih' file, Flote recognizes the directory as originating from a Photron 
camera. These video files are saved with the first file as _000001.jpg instead of number 
zero. For such directories, Flote will automatically add +1 to the file number. However 
in telling Flote which files to load, you should still regard the first frame as being zero 
numbered. 

If you were unable to save using the convention 'filename'='folder_XXXX.jpg' then 
toggle the 'File→Alphanumeric file order' to be checked. Flote will assume that the file 
stack is simply saved in alphanumeric order. When it loads a video, it will each time 
make a list of all files in the directory and open the appropriate subset. This is slower 
than when it can assume that frame numbers are appended to file names, with the first 
frame being zero. If you have any trouble loading videos, the first thing to try is 
applying the "Alphanumeric file order" setting. 

If there are a large number of frames in the directory and/or the directory is hosted on a 
remote server, it could take around 30 seconds for the 'Select directory' window to close 
and the first file to display. 

Note that images that are not 512x512 are stretched to fit the display. This may affect the 
display of tracks and other visual annotations, but does not affect the actual analysis. 

3. 1. Finding the head centroids. 

The 'Head Locate' part of the main window allows you 
to adjust parameters for finding the head centroids. 
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Click  the  Bpass  button.   This  shows  the  bandpass  filtered  image  that  will  be  used  to  find  
head  centroids.   The  bandpass  controls  are  the  'Noise  size'  and  the  'Object  size'.   Objects  
smaller  than  the  'noise'  size  (in  pixels)  or  larger  than  the  'object  size'  will  be  smoothed  

out.   For  larval  fish  whose  length  on  the  image  is  about  50  pixels,  
using  a  noise=3  and  object=12  sufficiently  blurs  the  eyes  and  
head  into  a  single  object.    

Now p lay  with  the  'diameter'  and  'density'  functions.   These  are  thresholds.   Only  objects  
whose  diameter  and  intensity  respectively  are  larger  than  these  numbers  will  be  
recognized  as  head  centroid  positions.   For  larval  fish  recorded  at  the  recommended  
image  size,  diameter=13  usually  suffices.   Density  will  depend  on  your  illumination.    We  
generally  use  density=100.  

To  check  your  settings,  make  sure  that  the  parameter  Display→Head  
Positions  is  on,  then  click  'Heads'.   All  the  fish  should  be  recognized,  with  a  
crosshair  showing  the  position  of  the  head  centroid  for  each  fish.  

For  more  information  on  the  particle  identifying  algorithm  implemented  see:  
Crocker,  J.  and  Grier,  D.  (1996).  Methods  of  Digital  Video  Microscopy  for  Colloidal  
Studies.  Journal  of  Colloid  and  Interface  Science  179,  298-310.  

3.  2.  Finding  the  body  curvature  

The  body  segment  part  of  the  main  window c ontains  
controls  for  changing  how t he  larval  curvature  is  
modeled.  

The  body  is  modeled  as  a  series  of  (at  least)  three  segments.   The  number  of  segments  
can  be  set  in  the  'Segments'  field.   For  tracking  larval  fish,  we  use  3  segments.   The  length  
of  the  segments  is  set  using  the  'Seg.  length'  slider  bar.   Two  factors  are  important  - the  
first  segment  should  end  just  before  the  caudal  extremity  of  the  swim  bladder.   The  head  

begins  to  bend  at  around  this  point,  so  the  segment  length  needs  to  end  here.   
The  second  factor  is  that  depending  on  your  contrast,  the  tail  will  begin  to  
thin  out  and  be  hard  to  recognize.   If  the  segments  are  too  long,  the  third  
segment  will  be  'jumpy'.   Generally  a  segment  length  of  11  or  12  is  suitable.  

The  'Max  bend'  parameter  is  not  generally  changed  - its  the  
segment  of  the  circle  searched  for  the  'next  segment'.   This  is  
set  at  220,  giving  a  maximum  segment  to  segment  angle  of  
110  degrees.  

There  are  four  methods  for  finding  the  segments,  which  can  
be  selected  under  the  Tracking  menu.  



  

  

 
               
             

        
 

                 
               
            

 
              

              
                 

                
    

 
              

               
              

                 
  

 
  

 

      
 

                  
              

    

     
 

              
             
            

               
            

             
                 

                
           

 
 

Orient line density - the default and usually most reliable. This method measures the 
density of bars radiating from successive initiation points and identifies the most intense 
bar as the continuation of the body axis. 

Orient point density - Searches only for the most intense point at the end of bars radiating 
from successive points on the body. This is sometimes more accurate in images with 
noise, for example when larvae are gridded in a high contrast array. 

Orient ellipse - Fits an ellipse to the centroid using David Fanning's fit_ellipse routine 
(www.dfanning.com) and extracts the orientation of the major axis of the fitted ellipse. 
The ellipse is fit using a box around the centroid whose width is specified by the 'radius' 
slider. This is not intended for larvae fish, but is quite good for measuring eye 
movements during optokinetic assay. 

Overlapping contours - Uses overlapping bars to measure body curvature. This is not 
useful for larval fish and is intended to allow measurement of the orientation of other 
organisms. The differences are that the first orientation bar is centered on (not emanating 
from) the centroid. Consequently the orientation range is from 0 to 180 degrees not a full 
360 degrees. 

Other examples: 

In addition there is a Low Contrast option in the 'Tracking' menu. If your light source is 
weak and contrast is poor, low contrast tweaks the line density algorithm to improve 
curvature analysis. 

3. 3. Finding the eyes 

The 'Eye Find' parameter is by default '1,3,3,400,12'. These numbers refer to the 
parameters passed to the bandpass function for finding eyes: noise size=1, object size=3, 
diameter=3, density=400, search radius=12. To check that these parameters work for 
your video, set the 'head locate' parameters with these settings. While the whole video 

field will probably become covered in 'head' check marks, there should be 
marks clearly identifying every eye of every fish. In poor illumination you 
might need to reduce the density to 100 for the eyes to be correctly found. If 
the image of the larvae is small, you might need to reduce the search radius. 
The search radius needs to be larger than the object size. 

11
 

http://www.dfanning.com


  

  

                  
                 

              
              

   

     
 

          
           

           
             

              
        

                 
                   

   
 

                  
                  

                  
                
              

                 
                 

                 
                  

      
 

                     
                

          
 

      
 

              
               

                 
        

 
              

 
             

   
 

By default, Flote only finds eyes in the first frame - this is useful to exclude larvae which 
are lying on their side or contrast elements which are not larvae. However, by finding the 
eyes in every frame, Flote can also determine whether the larvae maintain an upright 
posture throughout their movement. This slows down tracking, but can be enabled by 
selecting Tracking→Follow eyes. 

3. 4. Setting image regions 

Often you will want to exclude contrast elements at the 
edge of the image, for example the edge of the recording 
arena. Two options in the 'Image subset' area allow you 
to do this. The 'Frame' field lets you specify a number of 
pixels from the edge to exclude - by default its set at 0. 
The 'Radius' slider excludes points outside a circle, 
centered in the middle of the image, whose radius is half the image width less the value 
of the radius slider. This is useful if you are recording inside the whole area of a Petri 
dish. 

The 'Wells' field lets you divide the field into an X by X series of sub-fields, where each 
sub-field is expected to contain just one fish. For example, set 'Wells' to 2 and press the 
Heads button. You'll see a 2x2 grid on the field. During tracking, each of the four 
squares is assumed to contain a single fish. If multiple elements are identified, only the 
darkest object will be analyzed. This is useful if the subdivisions correspond to 
individual wells in which fish have been placed. It is often difficult to prevent the 'Heads' 
algorithm from identifying parts of the well as larvae. However, so long as the larvae is 
the darkest object in the sub-field, it doesn't matter, only that larva will be analyzed. By 
default Wells should be set to '0', indicating that there is no division of the field and that 
every fish identified should be analyzed. 

If you set 'Wells' to 1, only one fish in the whole field will be analyzed. This can be very 
useful if you are tracking adult fish where both the head and the swim bladder are 
typically found as 'heads', but the actual head is darker. 

3. 5. Excluding false contrast elements 

Contrast elements are often misidentified as larvae - excluding these is critical to getting 
good tracking analysis. Ensure larvae are in very clean water with no dirt floating 
around. Avoid imaging the edge of the testing arena. Once this is optimized, the main 
three tools you have against this problem are: 

1. Setting the image regions to exlude regions with false contrast elements (see 3.4) 

2. Adjusting the head centroid parameters so that false contrast elements are not 
identified as fish 
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3. Adjusting the eye-find parameters so that false contrast elements which are identified 
as fish, do not have 2 eye spots identified. These elements are then later able to be 
excluded from analysis. 

4. Tracking a single video 

4. 1. Loading the Video 

Load in the frames you want to track. Select File→Load subset and 
in the box that appears enter the number of the first frame in the trial, 
and the number of the last frame in the trial. The option 'skip' allows 
you to only load every Xth frame. In general leave this at 1 - all 
subsequent kinematic analysis for larval zebrafish requires videos to 
be performed at 1000 frames per second. 

For example, if each trial was 400 frames, and the folder contains 
8000 frames (20 trials of 400 frames) and you want to look at the 
third trial, enter 800 beside 'first frame', 1199 beside 'last frame'. 
Then click Load. 

Alternatively, if the each folder contains only a single trial (for example a 1 second long 
recording of 1000 frames), after selecting the working directory you can choose 
File→Load whole directory and the full 1000 frames will be loaded. Memory is limiting 
but a computer with 2 Gb memory should be able to load and track at most around 2000 
frames. Typically we analyze 100-400 frames (i.e. 0.1 to 0.4 sec). 

Large videos, especially when transferred from a remote computer can take several 
seconds to load. You can see the progress of loading a video in the dialog box above the 
image. 

Check that the video has been loaded correctly. The slider bar above the image shows 
the frame number being displayed. If you move the slider bar, the frame number should 
change and the appropriate image displayed. To play the whole video, press the Fwd 
button to the right of the slider bar (and to play it backwards, press the Back button to the 
left of the slide bar). The frame-rate slider sets the 'skip' - by default its set at 5, 
meaning that playing the video will display frame 0,5,10,15 etc. For very long videos, 
you will likely want to adjust this to 10 or 20. For saving videos (see section, ) you will 
want to set this number to 1 so as to save every frame in the video. 

When you are finished analyzing a given trial, you can select File→Next subset or click 
the Next button to retrieve the next trial. Conversely the Prev retrieves the earlier set of 
frames. Example, if you loaded the 400 frames from frame 800 to frame 1199, selecting 
the next trial would load frames 1200-1599, while selecting the previous trial would load 
frames 400-799. 
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Once you have loaded the first video, the File→Load subset menu allows you to enter a 
trial number. If you specify a trial it over-rides any text in the 'first frame/last frame' box. 
For example, if each trial is 120 frames, and you select trial 12, then frames 1440 to1559 
will be loaded. 

4. 2. Setting Tracking Options 

There are two methods of tracking, selected by toggling the 
Tracking→Rapid tracking setting. The 'slow' method (option 
unchecked) is a simple implementation of the tracking 
algorithm of Crocker and Grier. The 'rapid' method (option 
checked) uses a similar approach (connecting nearest-
neighbors across frames), but simply institutes a local search 
across frames, after identifying initial object positions. For all 
applications we have tried, the 'rapid' method is as accurate and 
much faster. It is possible that in a very crowded field, the 
'slow' method would work better, but in general keep Rapid tracking on. Rapid tracking 
has a maximum allowed object size of 25, or 50 if the 'Broad Field Search' is checked 
for larger objects the slow method is necessary. 

There are two other options under the Tracking menu, both of which are left unchecked 
by default. They only work under Rapid tracking mode. These options are not useful for 
most applications and should usually be left unchecked. 

Search lost points - if the larvae becomes fainter during the trial (for example, due to 
waves of water passing across it or fast movement introducing a slight blur) the density 
threshold will be automatically reduced until the particle is located again. Having this 
option on can greatly slow down tracking - however the fact that it is doing so means that 
more larvae are being successfully tracked. You can try reducing the initial 'Density' 
threshold to prevent larvae being lost. 

Broad search field - by default, during rapid tracking, a local search for the nearest object 
in a 50 pixel box around the position of the object in the last frame. If this box is 
checked, the search is expanded to 100 pixels. This is useful when: 

1. Tracking is being performed for reasons other than kinematic analysis, where the 
recording speed might be less than 1000 frames/second, and the larvae move further 
between frames. 

2. You need to set an object size greater than 25. With the 'Broad Field Search' checked, 
you can have an object size of up to 50. 

Rather than manually set the object detection and tracking parameters every time, once 
you are happy with the parameters, you can save the configuration by selecting 
Configuration→Save this config. Give the configuration a name and press 'Save'. To 
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reload the configuration, either select Configuration→Load Tracking Config or 
Configuration→<Saved Configuration Name>. 

4. 3. Tracking a video 

With a video loaded and all options set, click the Track button. In the dialog box above 
the video, you should see the progress of the tracking. First the object positions are found 
and linked into tracks. Second the orientation of each object is determined across frames. 
Tracking is finished once all objects have been oriented - for example the dialog will read 
'Orienting item 3421/3421'. 

If you are going to load and track many trials, it is convenient to set the File→Track on 
Load option. When set, after pressing the Next or Prev buttons, Flote will automatically 
track frames after they have been loaded. 

4. 4. Displaying tracked data 

The Display menu controls how the video is displayed on the screen, annotating it 
selectable options. 

The following options are toggle switches, turned on and off by selecting the option:
 
Tracks - displays the path followed by each object.
 
Head positions - displays the head locations.
 
Eye Positions - displays the eye locations.
 
Head Orientation - displays the first (i.e. head) segments.
 
Body Contours - displays all the segments.
 
Background - displays the video (leaving the annotations intact).
 
Number larvae - displays the number assigned to each object.
 
Neighbours - displays the nearest neighbour to each object.
 
Orientation trail - shows a 'trail' of the orientation in the previous 10 frames.
 

The Head Shape submenu contains various options for designating the head centroid. 
The Eye Shape submenu contains various options for displaying the eye positions 

Selecting Setup Colors opens a window in which the color assigned to the head, eyes, 
tracks, numbers and three body segments can be controlled. The Multicolor tracks toggle 
over-rides the color assigned to the larval number and track to give each larva a 
distinctive color. The Grayscale toggle over-rides any color selections with a default 
black and white palette. 

The Selected Object submenu controls how the selected object is 
displayed: 
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Zoom and Center - Toggles whether the zoom window keeps the head centroid of the
 
selected object in the middle of the window.
 
Highlight - Toggles the display of a circle around the head of the currently selected
 
object.
 
Mask others - Toggles the display of the head and body segments of all objects, or just
 
the selected objects.
 
Fix Rotation - Rotates the zoom window so that the head of the selected larva is always
 
facing to the left. This only operates if the 'Zoom and Center' has been selected.
 

Copy to file - Toggles saving of the image to an output file. Every time the image is 
changed, the current video display is saved to a '.tif' file in the 'C:\ftrack\images\' folder. 
This is very useful for making annotated videos. Simply toggle this on, then press the 
Fwd button beside the slider at the top of the image. Every frame will be annotated and 
saved in order. Remember to turn this option off! If there are files already in the 
'C:\ftrack\images\' folder, new files will be numbered after the existing files. 

Annotate Time Series - Flote can annotate the time series data onto the main window 
and/or the zoom window. First toggle on Display→Annotate→Time series then select 
the main or the zoom window to be annotated with the time series data this is currently 
being plotted (see section 6.) It is not possible to select a subset of the time series - every 
frame is included in the annotation. 

Annotate Stimulus - It is sometimes useful to represent the frames in which stimulus 
conditions changed. To do so, toggle the Display→Annotate→Stimulus, then select the 
main or the zoom window to be annotated. Next choose Display→Annotate→Setup 
stimulus and enter the first frame and the last frame to mark the stimulus. 

To make the annotation larger, for example if you are planning to save frames and 
compress them subsequently to make a movie, toggle on the 
Display→Annotate→Double Thickness option. 

If 'Use External' is selected then external IDL code is called to annotate the image. This 
is for future use only. 

To zoom on part of the window, hold down the right mouse button and drag the mouse 
across the area you want to highlight. A zoom window will appear, with an expanded 
view of the region. The physical size of the zoom window is fixed on the x-dimension 
(i.e. the zoom window is 500 pixels wide). So if you select a small horizontal region for 
zoom, the magnification will be large. The y-dimension of the zoom window is simply 
scaled proportional to the scale factor for the x-dimension. 

You can select a 'standard' zoom window dimension by checking one of the options in 
DisplayDisplay→Zoom Size. This will magnify a window of 100x100 or 200x200 pixels 
into the 500x500 pixel zoom window. The top left corner of the zoom box will be where 
you right-clicked. 
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After tracking, you can right click on a larva to highlight it and a zoom window will 
appear with the selected larva in the center. Doing this automatically sets the Zoom and 
Center option, so that the larva will remain in the center of the zoom window while it 
moves. 

Left clicking inside the zoom window will give you the pixel location in the message 
window. Dragging with the left mouse button depressed gives the dx, dy values and 
distance in the message window. This can be useful for making length measurements. 
Right clicking inside the zoom window puts the selected point in the center. 

Note that when Copy to file is toggled on, the zoom window will also be saved. This is 
useful for making enlarged videos of a part of the field. 

4. 5. Saving tracking information 

You can save the tracked information for a video by selecting Tracking→Save Tracking 
File. A file containing the position and orientation information will be saved in your 
default 'save tracks' directory (see section 1), with the file name 'track_eXXX.sav' where 
the XXX corresponds to the number of the video in the directory. 

Tracking files are proprietary IDL data files that can't easily be opened or viewed. To 
convert these files to tab-separated text files (easily opened in Excel) select 
Tracking→Convert tracks to text. Choose the directory containing the track files and 
press OK. Files in the selected folder will be copied to the 'C:\ftrack\' folder, with a '.txt' 
suffix. These files contain 10 columns. Each row specifies the position and orientation 
of a single object in a single frame of the video. 
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Fish  - the  number  assigned  to  each  object  in  the  video  
Frame  - frame  number  for  that  object  
x  - x  position  of  the  object  in  that  frame  
y  - y  position  of  the  object  in  that  frame  
mass  - density  of  the  object  
radius  - a  measure  of  the  object  size  
eccent  - a  measure  of  object  symmetry  
orient1  - the  orientation  of  the  first  (i.e.  head)  segment  of  the  object  
orient2  - the  orientation  of  the  second  (i.e.  midbody)  segment  of  the  object  
orient3  - the  orientation  of  the  third  (i.e.  tail)  segment  of  the  object  



  

  

     
 

                
               
                  

               
         

 
        

                
                   
                

 
 

               
               

            
     

            
                    

  
 

      
 

                 
            
  

 

 
 

5. Batch tracking multiple trials 

Flote is designed to automatically track multiple trials. First, to be clear on terminology. 
By 'trial' or 'event' we mean a single short video (typically 100-400 frames) which records 
the response of the fish to one stimulus. Generally, a given group of fish are exposed to 
multiple stimuli. Flote expects that a folder containing a stack of JPEG files with 
continuous numbering, in fact represents the multiple trials. 

For example, folder 'DRUGA_P01' contains files 'DRUGA_P01_0000.jpg' to 
'DRUGA_P01_7999.jpg'. In this case, we have tested drug A, with plate #01 of fish. 
The 8000 files might be 80 trials of 100 frames per trial, or 20 trials of 400 frames per 
trial. All these need to be individually tracked, resulting in 80 and 20 tracking files 
respectively. 

'DRUGA_P01' was likely only a single data point of the whole experiment. Thus, the 
folder 'DRUGA_P01' itself is inside a larger folder containing all the data for a given 
experiment. For example, you have a larger folder 'Startle_05212006' containing six 
folders 'DRUGA_P01', 'DRUGA_P02', 'DRUGA_P03', 'CONTROL_P01', 
'CONTROL_P02' and 'CONTROL_P02'. Each of the six folders contains 8000 frames, 
representing 40 trials each of 200 frames. In total then there would be 6 x 40 = 240 trials 
to track. 

5. 1. Setting up batch tracking 

Rather than load each video, press track, then save the tracking file, you can set Flote to 
batch track the whole experiment. Select Tracking→Setup Batch Tracking, to setup 
batch tracking. 

18
 



  

  

               
                

   
 

               
                  

                  
      

      
 

               
                  

             
                  

               
              

                  
                 

               
 

 
                  

                  
                

                 
            

 
           

              
                 
               

                
   

 
                 

                     
                  

           
 

                  
                  

                 
                

         
 

First, press 'Source'. The 'Source' is the larger directory which contains all the video 
folders. Note that in the setup program, you can specify default locations for the source 
and target directories. 

In the example above, you would select the folder 'Startle_05212006'. Press OK. The 
selected folder will appear in the box beside the Source button. Check that this is the one 
you meant to select. Flote will count the number of folders inside the selected folder. In 
the line below it should read 
'Contains 6 folders, each with ...' 

Next, you need to specify how many events/trials are inside each folder, and how many 
frames in each trial. Flote assumes that somewhere in the name of the folder is a string 
designating the experimental protocol in the form of "_Pxxx_" or "_Dxxx_" (where xxx 
are numerals). The first time you use a protocol, you will need to enter the number of 
trials and frames. However it will remember the settings for each protocol for future 
experiments. You can of course over-ride the remembered settings (which will then be 
replaced). If no string designating a protocol is found, or if the protocol hasn't been used 
before, Flote will guess that each trial is 120 or 100 frames long and enter these values 
accordingly. But this is likely wrong, you will probably need to enter these numbers 
yourself. 

You must specify a directory where the tracking files will be saved. This can be done in 
either of two ways. Either press the Target button and choose a target folder. This will 
then be entered in the box beside the Target button. Alternatively, just click the Auto 
button. A new folder, with the same name as the folder containing the video stacks, will 
be automatically created in your 'save tracks' directory (see section 1 above). 

To have different experiments tracked with different configurations, choose a preset 
configuration from the drop-down list. Alternatively, select the first option '[User set]' to 
have the tracking not alter the selected settings in the main window. Note that if you 
have two experiments in the list where the first specifies a configuration file, and the 
second is at '[User set]', then the second will use the configuration loaded when the first 
experiment is tracked. 

Finally, press 'Clear list' to remove any tasks that you may have specified in the past. 
Then click 'Add' to add this task to the bottom of the list or 'Add Top' to add this task to 
the top of the list. It should be displayed in the right-hand box, with the input directory, 
output directory, number of events and frames per event correctly specified. 

If you performed more experiments you'd like to track, you can add these to the task list. 
Just don't click 'Clear list' in between - you can make a list of folders that should be 
processed. This is useful if you want to record all day, then let the tracking process 
everything overnight. When your list is complete, press 'Save List', then 'Quit'. If you 
press 'Quit' alone, the list will not be saved! 
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The 'Filter' field lets you specify which folders will be tracked. If blank, all folders are 
tracked, otherwise only folders containing the text in the 'filter' will be tracked. As 
tracking is done in an alphanumberic order of folders, this can be useful if you would like 
to see data from particular trials quickly. 

5. 2. Running Batch Tracking 

Make sure that your tracking 
parameters are correctly set. The same 
tracking parameters are applied to 
every experiment in the batch list. 
When you are ready to start, select 
Tracking→Start Batch Tracking. A 
batch tracking window will be 
displayed. This shows what trial is 
being processed and has several 
control options, selected by hovering the mouse above the field. Flote will not respond 
immediately to selection of these control options - if it is in the middle of a tracking 
operation, you need to wait until it is complete. 

Batch tracking can be started while you are still recording videos. Once everything on
 
the original list is finished, the source folders where you are saving video files are re
checked every 30 seconds to see if new video folders have appeared. If so these are then
 
tracked. This is useful if you are recording on one computer and have another free to
 
start tracking.
 

The batch control options are:
 
Run - continue batch tracking.
 
Quit1h - track until everything is finished. After 1 hour in which no new videos are
 
saved in the source directories, quit.
 
Quit - Quit now.
 
RunQuit - track until everything is finished then quit.
 

If you have several computers networked, you can set multiple computers to analyze the 
same video files. Setup batch tracking on each computer, making sure that directory in 
which tracking data is saved is the same. You can then initiate batch tracking on multiple 
computers - each computer will first look to see if the relevant tracking file has already 
been saved. If so, it will skip to the next set of frames. For large experiments, having 
two or three computers analyze data can dramatically increase the speed of tracking. As 
a rough guide, analyzing an experiment with 100 folders, each containing 8000 frames 
(eg 20 trials of 400 frames) should take two computers working collaboratively about 10 
hours. 

In addition to the tracking files, the output folder contains a file 'log.txt'. This file, which 
can be opened by a word processor, contains information about the identity of the 
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computer which performed the tracking, time and details of the configuration used. Each 
time the tracking started, the log file will be updated with this information. If multiple 
computers are used, they will all write to the log.txt file, allowing a quick check that the 
configurations were indeed the same. Network privileges may prevent some computers 
from writing to the logfile, in which case you will be notified of the error when tracking 
begins and the log file will not be updated. 

To analyze the files created by batch tracking, see section 8. 
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6. Analyzing Time Series Data 

After tracking the video, left click near the larva you are interested in. The larva should 
be designated by a circle around its head location (assuming you have Display→Selected 
Object→Highlight turned on). The dialog box will display two lines of information: 
1. The Pixel location in (x,y) coordinates clicked and its intensity. 
2. The number of the larva selected, its (x,y) coordinates and orientation in the frame 
selected. 

A 'Time Series' window will open to the right of the main window. The time series 
window contains information on selected parameters for the highlighted larva. The value 
of each parameter across frames is shown. If this window is not desired, to prevent 
screen clutter, you can toggle its visibility using Windows→Hide Time Series. 

6. 1. Selecting time series data fields
 

A variety of parameters can be 
displayed in the columns of the 
Time Series window. Select which 
parameters are displayed by 
opening the Analysis→Select 
Params window. 

Click the checkboxes you want, 
then press Save and Quit. The 
Default buttons will mark two 
different subsets of the checkboxes 
that are typically useful. The 
checkboxes available are: 
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X  Position  - x  coordinate  of  the  object.
  
Y  Position  - y  coordinate  of  the  object.
  
Change  X  Pos  - movement  in  x  position  from  the  previous  frame.
  
Change  Y  Pos  - movement  in  y  position  from  the  previous  frame.
  
Movement  - total  movement  in  x,y  position  from  the  previous  frame.
  
Experimental  - not  yet  implemented.
  
X-X(t0)  - x  coordinate  relative  to  initial  position  (i.e.  in  frame  0)
  
Y-Y(t0)  - y  coordinate  relative  to  initial  position  (i.e.  in  frame  0)
  
Orientation  axis  1-4  - orientation  of  body  segments  1  to  4  respectively.
  
Change  axis  1-4  - change  in  orientation  of  body  segments  from  frame  to  frame
  
(maximum  change  is  180  degrees,  or  90  degrees  when  overlapping  contours  are  used).
  
Trend  axis  1  (slope)  - slope  of  the  linear  fit  to  the  head  orientation  function.
  
Trend  axis  1  (chi)  - chi-square  error  of  the  above  function.
  
Ax1-Ax(t0)  - head  orientation  relative  to  initial  orientation.
  
Ax3-Ax3(t0)  - tail  orientation  relative  to  initial  orientation.
  
Ax1  mod  90  - head  orientation  converted  to  a  0-90  degree  angle.
  
Curvature  - sum  of  the  angle  between  segment  1&2  and  the  angle  between  segment  2&3.
   
A p ositive  value  means  a  leftward  bend  (be  sure  to  check  that  your  optics  do  not  invert
  
the  image).
  
Change  curvature  - change  in  curvature  from  frame  to  frame
  
Trend  curvature  (slope)  - slope  of  the  linear  fit  to  the  curvature  function
  
Trend  curvature  (chi)  - chi-square  error  of  the  above  function
  
Abs(curvature)  - sum  of  the  absolute  value  of  the  angle  between  segment  1&2  and  the
  
absolute  value  of  the  angle  between  segment  2&3
  
Change  abs(curve)  - change  in  the  abs(curvature)  from  frame  to  frame.
  
Tail  curvature  - sum  of  the  angle  between  segment  2&3  and  the  angle  between  segment
  
3&4
  
Neighbour  distance  - not  yet  implemented.
  
Neighbour  orientation  offset- not  yet  implemented.
  
Brightness  - density  of  the  head  centroid
  
Radius  - a  measure  of  the  size  of  the  head  centroid
   
Eccentricity  - a  measure  of  the  symmetry  of  the  head  centroid
  

6. 2. Saving time series data 

The values in the Time Series window can be saved by 
selecting Analysis→Save Time Series. The default file 
is 'C:\ftrack\singlefish.trk'. The output file is a tab 
separated text file that can be opened in excel. Note 
that if a file of the specified name exists, it will not be 
over-written, but the information appended to the end 
of the file. 
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Not all frames need to be saved. In the 'Times Series Analysis' area of the main window, 
the frames that will be saved are specified - the default is '0' to '399'. By changing these 
numbers, only the designated subset will be saved. 

6. 3. Plotting time series data 

To plot the time series, click on the column that you want to plot in the Time Series 
window then press the Plot button in the ' Times Series Analysis ' area of the main 
screen. A graph of the parameter against time will appear in a new window. The title of 
the graph is the parameter being analyzed. For example: 

The vertical red line with the number at the bottom indicates the current frame and the 
value of the parameter plotted in the current frame. 

Selecting a frame: Left clicking inside the Plot Window will change the frame displayed 
on the main image screen to the frame selected in the plot. To plot a different parameter, 
simply click on it in the Time Series Window. The red line in the plot window shows the 
frame selected and the value of the parameter selected at that time point. 

Setting the Y-axis: To change the Y-axis of the graph, enter the desired value in the box 
'Y-ax.'. If a single number is entered, the Y-axis is from -value to +value. If two 
numbers are entered (eg '0,200') the Y-axis will be set to those values. If you enter a 
blank in the box, the Y-axis will be automatically set, using the maximum and minimum 
values of the parameter respectively. 

Setting the X-axis: To change which frames are plotted, enter new values in the 'Frames' 
fields in the ' Times Series Analysis' part of the main window. To set the x-axis to go 
from zero to the maximum frame number, click the 'Frames' button. 

Calculating gradients: Holding the left button down and dragging within the Plot 
Window produces a light blue line showing the frame where the dragging commenced. 
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At the top of the light blue line is a bracket showing the number of frames and the 
difference between the parameter value at the beginning and end of the drag. The 
gradient of linear fit to the region between the blue line and the red line is calculated and 
shown as "m=". For convenience in copy-pasting into other documents, this value is also 
displayed in the message window. 

As it is often useful to find the gradient for the same time window across larvae and 
framesets, the red-blue window is remembered when you click on new larvae or load new 
video sets. 

Due to a quirk in the way IDL handles interactive windows, having a time series graph 
open usually interferes with attempts to select and open a new set of frames. While there 
is no problem click the 'Next' or 'Prev' buttons to get the adjacent frameset from the same 
folder, attempts to select a new folder for analysis using File→Select Video Directory 
will sometimes fail. If this is a problem, close the time series graph before opening a new 
folder. 

6. 3. 1. Smoothing time series data 

There are three ways to smooth the time series data. Right clicking inside the Plot 
Window superimposes the Fourier smoothed trace (in black) with frequencies greater 
than 100 Hz removed. Right clicking a second time shows only the Fourier smoothed 
trace - in this condition the text at the bottom of the vertical red line shows the value of 
the Fourier smoothed trace. This is useful because the 100 Hz smoothed data set is used 
by Flote for determining movement episodes. 

Entering a number in the 'Freq. Filter (Hz)' box allows for Fourier smoothing at the 
desired frequency. When anything is entered in the box, the zero frequency component is 
also removed. When a single number is entered in the box, everything above that 
frequency is also removed. When two numbers are entered separated by a comma, 
frequencies below the first number are removed, and frequencies above the second 
number are removed. 

Entering a number in the 'Box' box performs box-car averaging of the trace, using a 
window of the number of frames entered in the box. For example, is 3 is entered, then 
the value at a time t becomes the average of t-1, t, t+1. 
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6. 4. Position and Orientation 

Orientations in Flote are in degrees, with 
0 being horizontally to the left. The x,y 
positions start at the bottom left of the 
screen. After tracking a larvae, left 
clicking on it brings up its number, 
centroid coordinates, orientation and 
orientation relative to a set point 
('AVec') in the message window. 

You can set the target point for the 
'AVec' measurement by choosing 
Analysis→Misc Parameters and setting 
the x,y coordiates appropriately. This 
number is between -180º and +180º, 
with negative numbers meaning the 
target point is to the right of the fish and 
positive numbers meaning that it is to its 
left. 

For example, after loading and tracking a video, you click near a larvae on the screen. 
The message window might now display the following text: 

001 (163.1,232.9) Orient:263.3 AVec: -117.0 

This means that you have clicked on larvae #1. Its x,y position in the current frame is x
163.1, y=232.9. Its absolute orientation is 263.3º (almost exactly upward), while its 
orientation relative to a target point (in this case [512,0], the lower right hand corner) is 
117.0º. 
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7. Kinematic Analysis - Single Trials 

Flote uses the raw data on position, orientation and body curvature to automatically 
classify the type of motor pattern represented by each movement event. This is the main 
purpose of Flote - to facilitate observer-independent, high throughput analysis of 
behavior. 

An important warning - behavioral classification using kinematic analysis is very 
sensitive to the tracking and analysis parameters. Before embarking on large scale video 
recording, batch tracking and kinematic analysis, it is crucial to spend several hours 
manually loading videos into Flote, tracking and validating the behavioral classification. 
If this is optimized, you should be able to get attain a very low rate of mis-classification, 
less than 1 in 20, and those mis-classified events should be ones where the observer 
might also be uncertain. 

Another key point is that because behavioral classification relies on the kinematic 
properties of movement, results obtained from analysis of mutant or drug manipulation 
need to be carefully analyzed. It is imporant to rule out that the effect is not a change in 
the kinematics of a movement such that it becomes mis-classified. For example, when 
analyzing the twitch twice mutant response to Dark Flash stimuli, we were surprised to 
see that they had a reduced frequency of O-Bend response and an increased frequency of 
J-Bend responses. However on careful inspection of the videos and kinematic data, it 
was clear that O-Bend kinematics are slowed down in twt such that the behavior now 
looks like a J-Bend. Thus for analysis purposes we aggregated O-Bend and J-Bend 
results. 

Finally, while kinematic analysis and behavioral classification in Flote works well, the 
details of movement kinematics are not accurate for scoot maneuvers. This is because 
scoots (slow swims) are initiated with an extremely fine flexion of the distal tail, which 
Flote does not accurately measure. Thus Flote frequently identifies scoots only during 
the second peak of the sinusoid - so kinematic details of scoot movements are not 
reliable, although the classification as a scoot is still accurate. 

7. 1. Setting Behavioral Thresholds 

First, you need to setup the thresholds used for behavioral analysis. Select 
Analysis→Setup Behaviors. The fields are: 

Analyze from frame - usually set to zero, meaning that frame 0 is the first frame analyzed. 
However you can set this to a larger number if you are not interested in movement events 
before this time. 
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Stimulus at frame - if there is a stimulus, you should enter the frame number when the 
stimulus began (this is an absolute number, not relative to the first frame used. So if the 
stimulus was at frame 210 and you decide to analyze from frame 200, you should set this 
value to 210, not 410). 

MAX SLC limit (ms) - the window, in milliseconds, from the stimulus, during which 
movement events are considered SLC startle responses. Note that not all events initiated 
during this window will be classified as SLC responses, only those with sufficient bend 
angle and/or angular velocity. If no startle responses are expected, set this number to 0. 
Depending on temperature, this number is between 12-20 ms. 

MAX LLC limit (ms) - the window, in milliseconds, from the stimulus, during which 
movement events are considered LLC startle responses. SLC responses are designated 
first, so if a response occurs within the SLC time limit, it will be classified as a SLC 
response. If a response occurs after the SLC time limit, but before the LLC time limit it 
will be an LLC response. Only responses which are larger than the scoot/turn threshold 
(below) are considered LLC responses. If no startle responses are expected, set this 
number to 0. Generally, this number is set at the size of the recording window. 

Scoot/Turn thresh (deg.) - The maximum curvature for a scoot (generally 35 or 40 
degrees depending on temperature) before it becomes a candidate for a turn/C-bend. 

Turn/O-Bend thresh (deg.) - The maximum change in head angle for a routine turn before 
it is classified as an O-Bend (generally 95 degrees, depending on temperature). 

Distance Integral (ms) - The frame interval for summing displacement to calculate the 
distance. For example if this is set to 1, the distance is calculated by summing the 
movement between frames for all frames. If it is set to 5, distance is calculated by 
summing the movement between every 5th frame. 
Eyes - The number of eyes detected for the larva to be included in the analysis. This field 
should be set as [minimum number of eyes],[maximum number of eyes]. For example 
setting the field as "1,2" will include larvae detected as having one or two eyes as 
included. Generally anything with more than two eyes is not a larva and should be 
excluded from analysis. Larvae lying on their side are seen as having a single eye and it is 
often useful to exclude these by setting this parameter to '2,2'. 

There are also several toggle switches under Parameters. 

Ignore track errors - If a large jump in the head angle or body curvature occurs, this 
generally indicates a tracking error. Similarly, if a larva is very close to the edge of the 
recording field, a tracking error is generated. For startle analysis, we generally set this 
toggle on ; for swimming analysis we leave it off. 

Ignore swimmers - The software attempts to detect larvae moving before the stimulus 
frame is reached. If this toggle switch is set, these larvae are indicated as 'swim'. If it is 
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not set and there is a distinct movement initiation before the stimulus frame, the 
movement will still be classified. We usually set this to on. 

Ignore drifters - Flote detects larvae with an above threshold displacement before the 
triggers. In many cases these larvae are swimming and can be excluded using the 'ignore 
swimmers' toggle. However occasionally larvae are simply drifting in which case they 
can be excluded or included in the analysis using this toggle. If this toggle switch is set, 
these larvae are indicated as 'swim'. 

Strict SLC kinematics - If set, responses are only classified as SLC if they have a peak C1 
angular velocity of greater than 18 and a C1 duration of less than 10. We usually leave 
this off. 

Strict SLC latency - If set, responses are only classified as SLC if their latency falls 
within the 'MAX SLC limit' (specified above). We almost always set this to on. 

After setting the parameters, save them, using File→Set. If this parameter set will be 
used frequently, then save it as a configuration, using Configs→Save New Config. In the 
dialog box, give the configuration a name and press the save button. Next time you open 
the Setup Behaviors window, your configuration should be present under the Configs 
menu. You still need to save it using File→Set before closing the window. 

Finally close this window using File→Quit. 

7. 2. Selecting Analysis Method 

Next you should select an analysis method. In the 
'Kinematic Analysis' area there are two options: 

Head - uses the orientation of the head segment only to measure responses. This is 
suitable for measuring acoustic startle responses and is NOT appropriate for measuring 
scoot or routine turn movements. 

Fourier - uses the curvature function to measure responses. This is much more sensitive 
and is suitable for measuring scoots and turns. It is not recommended for measuring 
startle responses. 

Angle threshold - designates the sensitivity for picking up movements. For 'head 
analysis' this value means the change in head angle that must occur over a three 
millisecond window to identify a C-bend. This value defaults to 8, but can be set to a 
higher value for example 16 if spurious movements are being picked up. For 'Fourier 
analysis' this value refers to the derivative of the smoothed curvature function used to 
identify the beginning of a movement sinusoid and should be left at the default value of 
2. 
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7. 3. Kinematic Analysis 

Once you have set the behavioral thresholds and analysis method, click 'Analyze' in the 
'Kinematic Analysis' part of the main window. The 'Kinematic analysis' window contains 
information about the kinematics and behavior of each larva. Each row represents a 
single larva, with the number corresponding to the number in the video. Clicking on a 
row will highlight the corresponding larvae and vice versa. 

Ignore for a moment the first column. The other columns (in order) give the details of the 
kinematics of movement bouts. The columns, in order represent: 
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c1lat  - The  time  at  which  movement  was  initiated
dur  - Duration  of  the  first  movement  sinusoid  
ang  - Change  in  head  orientation  during  the  first  movement  sinusoid  
mav  - Maximal  angular  velocity  achieved  by  the  head  in  the  first  movement  sinusoid  
swvel  - Swim  velocity  (pixels/time)  
axis  - Maximal  curvature  at  the  peak  of  the  first  movement  sinusoid  
c2dur  - Duration  of  the  second  movement  sinusoid  
ang  - Change  in  head  orientation  during  the  second  movement  sinusoid  
mav  - Maximal  angular  velocity  achieved  by  the  head  in  the  second  movement  
sinusoid  
axis  - Maximal  curvature  at  the  peak  of  the  second  movement  sinusoid  
displ  - Straight-line  displacement  of  the  larva  from  the  first  to  the  last  frame..  
swcyc  - Number  of  half  swim  cycles  after  the  first  two  movement  sinusoids  (if  this  
number  is  negative,  it  means  the  fish  was  still  swimming  at  the  end  of  the  recording  
period.   eg  -5  means,  there  were  5  tail  flips,  but  the  fish  was  still  swimming  when  the  
recording  finished).  
rhythm  - Average  duration  of  a  swim  half  cycle  
swmag  - Average  change  in  body  curvature  during  a  swim  half  cycle  



  

  

 
                  

             
          

 
            

               
            

               
    

 

    
 

                 
             

swyaw  - Average  change  in  head  orientation  during  a  swim  half  cycle  
t_end  - Time  at  which  movement  ended  
e_sw   - Larva  should  be  excluded  from  analysis  because  moving  before  stimulus.  
e_oj  - Larva  should  be  excluded  from  analysis  because  orientation  measurement  error  
e_ed  - Larva  should  be  excluded  from  analysis  because  too  close  to  screen  edge  
e_tk  - Larva  should  be  excluded  from  analysis  because  position  tracking  error.  
eyes  - Number  of  eyes  found  anterior  to  the  head  centroid  
traj  - Trajectory  of  the  larvae  (angle  moved  at  relative  to  initial  orientation)  
dist  - The  curved  distance  moved  by  the  larva  
frames  - Number  of  frames  for  which  the  larva  was  tracked.  

If you are seeing a lot of non-zero 'E-Oj' or 'E-tk' (more than 10% of responses) then you 
need to adjust your video recording or tracking parameters. Generally improving lighting 
and reducing extraneous contrast elements (i.e. dirt) will improve performance. 

For angle and curvature measurements, the values are directional - negative values 
designate turns made in the opposite direction to positive values. In our system, negative 
values indicate rightward bends. However, as cameras and video recording software 
often reverse images, you should perform some tests to check whether this is true for 
your system as well. 

7. 4. Behavioral Classification 

The first column specifies the type of motor pattern executed by the larvae in the video.
 
This is based on the latency and kinematics of movement. The possibilities are
 

Swim  - Larva  initiated  movement  before  the  stimulus  arrived  (often  the  larva  is  already
  
swimming  at  the  beginning  of  the  video).
  
SLC  - A  'Short  Latency  C-bend'.   These  are  Mauthner  initiated  startle  responses,
  
initiated  at  short  latency  to  the  stimulus.
  
LLC  - A  'Long  Latency  C-bend'.   These  are  non-Mauthner  responses,  initiated  in  a
  
second  wave  after  acoustic  startle  responses.
  
Turn   - A r outine  turn.
  
TurnO  - An  O-bend.
  
Scoot  - A f orward  swim.
  
Burst  - A l arge  amplitude  forward  swim.
  
J-Bend  - A J -Bend  (note  this  is  not  yet  tested  and  should  not  be  relied  on).
  
Excl  - Tracking  error  occurred  (see  below).
  
---   - No  movement  observed.
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8. Batch Kinematic Analysis 

After batch tracking the video files, you will have a directory of '.sav' files. These are 
then be analyzed in batch mode. You can now close the flote.sav program, and open the 
bathan.sav program. 

The basic set of operations to analyze a folder of tracking files is as follows. 

1. Select the folder contains the set of tracking files 
2. Select a configuration from the pull-down menu 
3. Open the behavioral classification menu by pressing 'Setup' 
4. Run the batch analysis by pressing 'Single' 
5. Analyze the results by pressing 'Results' 

8. 1. Specifying Input/Output Files 

Input Folder 
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Click the input folder button to select the folder containing the set of 'track_***.sav' files 
for analysis. After you have selected the folder, it should appear in the box beside the 
button. 

Output Folder 

Either: 
(1) Click the output folder button and select a directory where the analysis files will be 
saved. 
(2) Enter the name of a folder in the box beside the button. A directory of this name will 
be created inside the 'input folder' directory. If a directory of this name already exists, the 
analysis files inside will be over-written. The name you enter here is purely descriptive 
and has no influence on how the analysis is performed. 
(3) Leave it blank and a name will be automatically assigned. 

Filter 

Only tracking files in the input folder whose name contains the text in 'filter' will be 
included in analysis. By default this is blank, so that all files in the folder are used. 

Append Output 

By default this is not checked and a new sub-directory of the name specified is created in 
the 'input folder' (as described above). If a directory already exists, the files in it will be 
over-written. 

If this box is checked, then files in the output folder are not over-written, rather the new 
analysis is added to the end of the existing files. 

Set name: 

Normally this is left blank. The name of each set is then simply the name of the first file 
in that set. 

For example, if a given group of fish (setA) was tested 30 times, then there will be a list 
of files in the tracking input folder 'track_setA_e00.sav ... track_setA_e29.sav'. The set 
will be called 'track_setA_e00'. 

When text is entered in this box, the name of the set is exactly as specified in this box. 

When text is entered in this box and the 'Prepend' button is checked, the text is added to 
the start of the first file name to create the name of each set. Thus if the text is 'trp1' then 
the name of the set will be 'trp1_setA_e00'. Similarly, if the 'Append' button is checked, 
then the text is added to the end of the first file name, for example 'setA_e00_trp1'. 

Several of the ROI functions will automatically modify this field. 
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Trials per set 

This number means how many tracking files will be averaged to form a single line in the 
c1_analysis.trk output file. This number generally specifies how many trials each group 
was subjected to. 

For example, if a given group of fish was tested over 30 trials, you would normally enter 
30 in this box. The percentage of fish responding with various types of motor pattern is 
then calculated as an aggregate of all trials. So if across 30 trials, there were 500 
analyzable larvae identified and 78 O-Bend events, the %O-Bend=15.6. 

However, note that this number can be used creatively to perform different sorts of 
analysis. In the example above, if you set the number to 1, then each line in the output 
file will represent a single trial. You can then determine whether there is a change in 
behavior over time (habituation or adaptation). Alternatively, you could set the number 
to 15, in which case each set of larvae will have two lines in the output file, the first 
representing trials 0-14 and the second 15-29, allowing a blockwise analysis to be 
performed. 

8. 2. Setup Analysis 

Setup the behavioral thresholds by clicking the 'setup' button in the middle of the 
window. Thresholds are set as in section 7.1 above. The 'Behaviors' box lists the current 
configuration. 

Select an analysis method (head/swim/displace) and set the threshold as for section 7.2 
above. 

8. 3. Specifying Trial Subsets and ROIs 

8. 3. 1. Trial Numbers 

Often you will only want to 
analyze a subset of trials in an 
experiment. For example, you may 
have recorded 40 trials for each 
group of fish, but 20 trials were 
with a control stimulus and 20 
trials with a test stimulus, in a pseudorandom sequence. Obviously, you then need to 
separately aggregate scores for those blocks. 
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To selectively analyze only certain trials, enter the list of trial numbers you wish to 
analyze. In the example to the right, only trials 1,2,4,8 etc will be analyzed. These 
correspond to tracking files ending in '_e01.sav', '_e02.sav', '_e04.sav', '_e08.sav' etc. 

8. 3. 2. Trial Presets 

If there are certain list of trial numbers you use frequently, you can 
save them using the Trials menu. When a list of trials is entered in 
the 'Include trial numbers' box, go to Trials->Save Subset, enter a 
name at the prompt. Trial lists are stored in the 
'C:\ftrack\subset_configs' folder. If you ever wish to delete items 
from the Trial menu, open the 'C:\ftrack\subset_configs' folder and 
delete the correspinding file. 

In the future, to use that set of trials, just open the Trials menu and 
select the set from the list. 

It is advantageous to give trials subsets which are used in the same experiment, names 
which are alphabetically ordered, as it will later allow you to automatically cycle through 
them (see section XXXX below). 

You can automatically generate the list of trial numbers when analyzing only even or odd 
numbered trials. If you have 40 trials, 20 of which are even numbered, then enter 20 in 
the 'Trials per set' box, then select 'Even #' from the 'Trials' menu. 

8. 3. 3. Preset pseudorandom sequence 

To the right of the trial numbers box are three checkboxes. 

None - clears the sequence in the trial numbers box and also clears whatever name is 
entered in the 'output folder' field. 

The other two boxes are for quickly entering a preset pseudorandom sequence, typically 
useful if there are 40 recording windows, divided into 2 groups (eg control and stimulus), 
which are intermingled according to the sequence set by these checkboxes. Activating 
the checkbox will enter a 20 number long pseudorandom sequence in the trial numbers 
box and name the output folder. 

8. 3. 4. Blocks 

If you only want to analyze a the first half of a sequence of trial numbers, click 'Block1' 
AND alter the number of trials per set to half the total number entered in the sequence 
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box. Similarly to analyze the second half of a sequence, click 'Block2'. This saves 
having the manually edit the trial numbers box. 

8. 3. 5. Gridded larvae 

In some experiments you may have individual 
larvae placed in separate wells of a grid, and 
wish to analyze them separately. Flote can 
analyze larvae in different sized square grids, 
with the first larvae being in the bottom left 
corner. Be careful if the images loaded into 
Flote are flipped relative to the 'real world'! 

It is not actually necessary to track the larvae 
using the grid option (see section 3.4.). When 
running analysis with a grid, Flote will in turn 
examine each region of the grid. Thus a fish in 
section 8 of the grid will always be called "-f8" 
irrespective of its original number during 
tracking. If more than one fish is found in a grid section, then Flote will assume that the 
additional fish represent contrast elements misidentified as fish. If you have set the 
tracking parameters correctly, these should generally be eliminated because they do not 
have the correct number of eyes - you should be able to tweak the 'eye finding' 
parameters so that incorrect contrast elements have zero 'eyes'. But if Flote cannot 
eliminate additional fish in a grid element using this procedure, then it will generate an 
error for that grid element in that trial. To see if errors are being generated in this way 
during analysis, turn on the Parameters→Report Track Errors option. 

8. 3. 6. Regions of interest 

In many cases it will be of interest to know whether larvae at a certain angle relative to a 
stimulus, or in a certain position within the testing arena behave differently from other 
larvae. 

You can choose to analyze only larvae of a certain 
orientation by entering the range of orientations acceptable 
in the ROI box. The format is [mid-orientation, range] in 
degrees. So entering 90,45 means including only larvae in 
the orientation range 45 to 135. Similarly entering 0,10 
would include only larvae whose orientation was in the 

ranges 355-360 and 0-5. 

It is crucial to be sure of how your image of the testing arena is transformed during 
imaging. Most systems produce a 180 degree rotation by the time the image is loaded 
into Flote: 
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Orientations in Flote are anticlockwise, with 0 degrees horizontally to the left (in Flote, 
corresponding to horizontally to the right in the real world). However in some cases you 
may want to examine larvae of an orientation relative to a different angle, or relative to a 
specific point. 

Orientation relative to an angle: Entering a single number in the 'relative to' box, makes 
the orientation ROI relative to that orientation. For example if you specify a range of 
orientations '90,20', then normally larvae whose orientation is between 70 and 110 would 
be included. But if you specified 'relative to' 45, then larvae between 115 and 155 would 
be included. Basically this just rotates the field so that the specified angle becomes zero. 

Orientation relative to point: Entering coordinates (eg '-100,256') in the 'relative to' box 
will include larvae whose orientation is in the range, relative to the angle from the 
position of the larva to the specified point. 

You can also specific a region of interest in x,y coordinates in the 'position' box. The 
format is [start-x, end-x, start-y, end-y]. So for example entering '50,200,60,250' would 
only analyze larvae in a box starting from point (50,60) to point (200,250). 

The number of larvae in a ROI can be found by looking in the xya_analysis.trk file in the 
'AreaID' column. The percentage of larvae in the ROI is in the '%inArea' column. 

8. 3. 7. ROI Presets 

You can have Flote automatically analyze preset sets of 
regions of interest using the ROI dropbox. If you check 
one of the options in this dropbox Flote will do the 
following: 

1. Enter a prefix for the ROI in the 'Set name' field. 
2. Enter the corresponding ROI in the ROI box. 
3. Run an analysis. 
4. Check the 'Append output' box. 
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5. Return to step 1 and cycle through until all ROIs for the set are analyzed. 

You will normally need to have clicked the 'Prepend' checkbox so that the prefix in the 
set name field is added to the beginning of the name, rather than become the entire name. 

Preset ROIs are available, covering sets of orientations as well as regions of the testing 
arena. These are illustrated below. Keep in mind that the diagrams representing 
orienation groups may be confusing. For example, for the 'Orientation 4 quadrants' ROI 
the diagram does not indicate that '_twd' larvae are those on the left of the testing arena, it 
illustrates that '_twd' larvae are those fish *anywhere* in the arena, which have an 
orientation from within 45 degrees of 0. 
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Orientation: 2 segments 

_fwd: orient 0,90
 
_rev: orient 180,90
 

Orientation: 4 quadrants 

_twd: orient 0,45
 
Rsid: orient 90,45
 
Lsid: orient 270,45
 
_awy: orient 180,45
 

Orientation: 5 sectors 

dA: orient 0,22
 
dB: orient 45,23
 
dC: orient 90,22
 
dD: orient 135,23
 
dE: orient 180,22
 
dD: orient 225,23
 
dC: orient 270,22
 
dB: orient 315,23
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Orientation 8 sectors 

dA000: orients 0,22
 
dB045: orients 45,23
 
dC090: orients 90,22
 
dD135: orients 135,23
 
dE180: orients 180,22
 
dD225: orients 225,23
 
dC270: orients 270,22
 
dB315: orients 315,23
 

Position: X segments 

Xseg1: 0,127,0,512
 
Xseg2: 128,255,0,512
 
Xseg3: 256,383,0,512
 
Xseg4: 384,511,0,512
 

Position: Y segments 

Yseg1: 0,512,0,127
 
Yseg2: 0,512,128,255
 
Yseg3: 0,512,256,383
 
Yseg4: 0,512,384,511
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If you select the 'User defined' option, Flote will open the file c:\ftrack\paths\userroi.txt. 
This file should be organized as series of lines where each line specifies a the name of an 
ROI and its parameters: Name;Orientation ROI;Position ROI. All these elements must 
be present. For example to analyze first the 90 degree angle centered on orientation 0, 
then the 90 degree angle centered on orientation 180, over the entire recording field, the 
file could contain these two lines: 
Sect1;0,45;0,512,0,512 
Sect2;180,45,0,512,0,512 

8. 4. Setting options 

8. 4. 1. Analysis Parameters 

When saving kinematic data to the summary.trk file, 
Flote can either save changes in orientation and curvature 
as values greater than zero (ie the absolute magnitude), or 
as values greater than zero for leftward turns, and less 
than zero for rightward turns. Toggle the 
Parameters→Rectify Neg Values ON to save only the 
absolute magnitudes. 

8. 4. 2. Reporting Options 

1. Report Stationary - By default, Flote does not include 
information about stationary larvae in the sumary.trk file 
because this makes the file very large and both batch 
analysis and subsequent results analysis can become 
extremely slow due to the large amount of data being 
manipulated. However, information on larvae that are 
deemed to be 'stationary' can be necessary when performing 
displacement analysis, so toggle this on to get information 
about the x,y coordinates, orientation and density of 
stationary larvae. 

2. Report Standard Deviations - Output cells contain standard deviations instead of mean 
values. 

3. Report File Errors - Track files are sometimes be corrupted, unable to be opened or 
containing scrambled data. Flote will simply skip these files, however, when checked, 
this option pops up a window detailing which files were corrupted. You should go back 
and retrack these files (just delete the tracking files affected and initiate tracking again -
Flote will skip over trials where a tracking file exists and just track trials where there is 
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no corresponding tracking file). However occasionally you will want to ignore the 
scrambled files and turn off error reporting - uncheck this option to do so. 

8. 4. 3. Calculation Options 

There are three ways that initiation frequences can be 
reported. 

1. The default way is to simply report the percentage of 
maneuvers of a given type (ie SLC, LLC, O-Bend etc). 
This represents the fraction of these maneuvers observed 
out of all analyzable embryos spotted. 

2. 'Unadjusted initiation counts' - toggle this on to get the 
'raw' number of maneuvers observed, ie NOT divided by the 
number of analyzable embryos. This is mostly useful when 

estimating directional bias - you may decide to exclude items where too few maneuvers 
were observed to give reliable data. 

3. Adjust % for SLCs. Normally, the number of LLCs is reported as the fraction of 
larvae executing a LLC out of all analyzable larvae that did not perform an SLC. 
Remove this toggle to get the number of LLCs as a fraction of analyzable larvae. 

8. 5. Loading and saving configurations 

<To be written> 

8. 6. Output files 

The sub-directory created by batch analysis contains four output files plus a 'config.txt' 
file which contains a record of the settings used for the analysis. 

1. summary.trk - Contains kinematic data on the first two bends (eg C-Bend and counter-
bend) for each movement episode measured. This is a tab-separated text file that can be 
opened in excel. 
2. swim_summary.trk 
3. c1_analysis.trk 
4. xya_analysis.trk 

These files can be opened in a spreadsheet (Excel) or used as input for the kinematic 
analysis 

A quick overview of the contents of each of the output files 
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summary.trk 

This file contains information on kinematic properties of the larvae during the first two 
peaks of the waveform of movement. For example for startle responses, this file contains 
information about the C-bend and Counterbend. 

Column A specifies the video sequence in which the event occurred. Here, a prefix was 
used so the file name begins 'dA_' instead of 'track_'. Thus first event was in the folder 
'i0000p3_00a'. The next section '_e03' means that during analysis, a subset of videos 
must have been selected, starting with the fourth video sequence in the whole stack. 
More usually it would read '_e00' meaning that analysis began with the first video in the 
stack. Finally, '_0000' refers to the number of the video within the subset selected. In 
this example, analysis began with the fourth stack, thus _0000 also the fourth stack. The 
next line is '_0001', which would refer to the fifth video in the stack. 

Column B specifies the identity of the fish in the video. Once you've identified the video 
sequence and fish, you can return to Flote and watch the movement of that particular fish. 
As an additional check, compare the initial (x,y) coordinates and orientation of the fish 
(columns D,E and F). 

swim_summary.trk 

This file contains information on kinematic properties of the larvae during swimming. 

c1_analysis.trk 

This file contains information on the behavioral classification of the larvae. 

File - the name of the first file in the set of trials combined for analysis. 

TotIDd - total number of fish identified over all the trials 

E-Ed - the percentage of fish excluded from analysis due to being too close to the edge of 
the image. 
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E-Jmp  - percentage  excluded  because  orientation  analysis  was  unreliable  (usually  poor  
image  quality)  

E-Trk  - percentage  excluded  because  due  to  a  tracking  error  

E-Sw  - percentage  excluded  because  larvae  was  already  moving  before  the  stimulus  time  

E-Eye  - percentage  excluded  because  the  object  did  not  have  the  specified  number  of  eyes  
in  the  first  frame  of  the  recording.   Note  that  this  can  be  a  very  useful  measurement,  as  if  
you  specify  that  the  eyes  should  be  '2,2'  and  are  confident  that  there  are  no  odd  contrast  
elements  in  the  video,  then  you  have  a  measure  of  the  number  of  larvae  that  are  not  
perfectly  upright.   This  is  thus  a  nice  surrogate  for  vestibular  function.  

TotAnd  - total  number  of  fish  analyzed  after  excluding  due  to  errors  

React  - percentage  of  fish  performing  any  response  (i.e.  not  stationary)  

SLC  - percentage  of  fish  performing  an  SLC   

LLC  - percentage  of  fish  performing  an  LLC   

AllTurns  - percentage  of  fish  performing  an  O-Bend,  R-Turn  or  J-Bend   

R-Turn  - percentage  of  fish  performing  an  R-Turn   

O-Bend  - percentage  of  fish  performing  an  O-Bend  

J-Bend  - percentage  of  fish  performing  a  J-Bend  

Swim  - percentage  of  fish  performing  a  Scoot  or  Burst  

Scoot  - percentage  of  fish  performing  a  Scoot  (slow s wim)  

Burst  - percentage  of  fish  performing  a  Burst  swim  

Other  - percentage  of  fish  performing  a  response  not  identifiable  by  Flote  

SLC(r)  - the  percentage  of  SLCs  initiated  in  a  rightward  direction  

LLC(r)  - the  percentage  of  LLCs  initiated  in  a  rightward  direction  

AllTurns(r)  - the  percentage  of  (Obends+RTurns+JBends)  initiated  in  a  rightward  
direction  

RTurn(r)  - the  percentage  of  R-Turns  initiated  in  a  rightward  direction  
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OBend(r)  - the  percentage  of  O-Bends  initiated  in  a  rightward  direction  
 
JBend(r)  - the  percentage  of  J-Bends  initiated  in  a  rightward  direction  
 
Sct(r)  - the  percentage  of  Scoots  initiated  in  a  rightward  direction  (note  - this  is  NOT  
reliable,  it  is  included  for  future  improvements)  

Bur(r)  - the  percentage  of  Bursts  initiated  in  a  rightward  direction  
 
BiasSLC  - the  tendency  for  SLCs  to  be  initiated  in  the  direction  of  the  target.   For  this  to  
be  useful,  you  need  to  specific  the  position  of  the  target  (see  section  8.3.6).   This  is  
calculated  at  2*[%SLCs  initiated  in  the  direction  of  the  target]-100.   Thus  a  score  of  +100  
means  all  are  target  directed,  -100  means  all  are  away  from  the  target.  

BiasLLC  - the  tendency  for  LLCs  to  be  initiated  in  the  direction  of  the  target  

BiasTurn  - the  tendency  for  (OBends+RTurns+JBends)  to  be  initiated  in  the  direction  of  
the  target  
 
BiasRTurn  - the  tendency  for  R-Turns  to  be  initiated  in  the  direction  of  the  target  

BiasOBend - the tendency for O-Bends to be initiated in the direction of the target 

xya_analysis.trk 

This file contains the information that can be used to make simple analysis of distance,
 
speed and orientation of the larvae.
 

File  - the  name  of  the  first  file  in  the  set  of  trials  combined  for  analysis.
  

TotIDd  - total  number  of  fish  identified  over  all  the  trials
  

TotAnd  - total  number  of  fish  analyzed  after  excluding  due  to  errors
  

AreaID  - total  number  of  fish  analyzed  that  are  in  the  ROI  and/or  Sector
  

%inArea  - percentage  of  all  fish  that  are  in  the  ROI  and/or  Sector
  
 
XVec  - mean  horizontal  displacement  from  center  of  all  larvae  identified  where  -1  and  +1
  
represent  the  extreme  edges  of  the  recording  field.
  

YVec  - mean  vertical  displacement  from  center  of  all  larvae  identified  where  -1  and  +1
  
represent  the  extreme  edges  of  the  recording  field.
  
 
AVec  - mean  orientation  of  the  larvae  relative  to  a  specified  orientation  or  target  position.
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T-Dist  - mean  distance  of  larvae  from  the  target  position  

AVecL  -  
AVecR   - 
XVecS  - 
YVecS  - 
AVecS  - 
SwVec   

9. Results Files 

10. Results Analysis 

Flote contains a simple utility to quickly graph and assess the significance of difference 
between experimental groups. 

Please note - this utility is for a quick analysis only!!! Flote does not give you the 
flexibility to appropriately set up or validate the statistical tests used. You must import 
the data into an appropriate statistical package like SAS or SPSS. 

10. 1. Loading Data 

Upon entering the statistical package, you are prompted for a file to load. Select any '.trk' 
file generating by the analysis package. At any time you can load a new file by selecting 
File→Load 

The currently loaded file is shown just below the menu bar. At any time this file can be 
refreshed from the hard drive by selecting File→Reload File 

In some instances you may have multiple experiments with the same 

10. 1. 1. Window Controls 

On selecting File→Quit all windows will be closed except for the Printer Out window.
 
This will remain so that you can add
 
data to the printer output window from
 
other analyses.
 

10. 1. 2. Groups Window 



  

  

                
    

 
            

 
                  

                   
     

 
                

                 
     

 
              

              
                

               
  

 

     
 

            
             

                
           

               
  

 
           

           
             

            
 

    
 

                  
          

 
               
            

This window shows the groups that match the selected set together with the value of the 
parameter selected. 

If no sets are selected then all groups are displayed. 

If a range of values has been selected, then the display is sorted so that groups inside the 
range of values are shown, with a '*' mark in front of their name to show that they fall 
within the selected range. 

If the range of values was selected for a parameter other than the one currently being 
displayed in the graph, then the brackets on the right show the value for the parameter for 
which the range was selected. 

The Sort button will reorganize the list alphabetically. The Delete button lets you 
eliminate a group from further analysis (see below). The Show Names checkbox (not 
implemented fully) by default is on, allowing you to see the group name and value. 
When off, it just lists the values for the selected group to facilitate cut/paste into 
statistical packages. 

10. 1. 3. Printer Out 

If you click on this window with the left mouse button, the 
contents of the main window will be copied to the printer out at 
that position of a 2 row by 4 column grid. If you click on the 
printer out window with the right mouse button, the contents of 
the main window will be copied at that position of a 4 row by 8 
column grid. 

To send the contents of this window to the printer, select 
Output→Print from the menu at the top. Similarly, the output 
window can be saved as a '.tif' file or copied to the clipboard 
from this menu. To clear the contents of the window, select 
Output→Clear. 

10. 2. Define sets 

The analysis package is built to allow you to easily clump a set of 'groups' (which may be 
plates, single fish or individual movement responses) into a 'set'. 

Sets are defined on the basis of having a common sequence of alphanumeric characters in 
their name. Thus if your have a series of groups called 
A_con_00a  
A_con_00b  
A_con_00c  
A_met_00a  
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A_met_00b  
A_met_00c  
B_con_00a  
B_con_00b  
B_con_00c  

Go to Define Sets and select the number of characters from the end you wish to ignore 
when matching names. For example, if you select '-1' then the first 8 characters will be 
used to define the group identity. In the example above you would end up with 3 sets: 
A_con_00, B_met_00 and B_con_00, each of which includes 3 groups (the first set 
would be A_con_00a, A_con_00b, A_con_00c). Alternateively use Define Sets→Enter 
End to open window with the first group name. Click within the group name to show 
how many characters from the beginning should be matched. 

Now, the 'sets' droplist will contain just the sets that have been defined in this way. If you 
select a given set, the matching groups will appear in the 'subsets' window. 

Important. Before defining the sets, you should remove groups that you want to exclude 
and setup parameters that help you to define appropriate sets - see below. Strange things 
can happen if you don't define the sets first. 

10. 2. 1. Remove unwanted groups 

Before defining sets, remove any groups that you want to discard from further analysis. 

To delete a single group, in the subset window, select a group to discard and press the 
delete button. 

To delete groups whose values lie outside a range, use the histogram window to select a 
range of values for a given parameter, by holding the mouse button down and dragging 
across the range you want, then press the 'cut' button. 

10. 2. 2. Parameters to identify sets 

Under 'Define Sets' a number of options provide flexibility in identifying sets. 

10. 2. 2. 1. Single Fish 

This should be checked if you have an experiment in which each group is actually a 
single fish so that the name of each group contains a string '-f1' (for fish 1) to -'f9' (for 
fish 9). If this is checked, Flote will automatically discard the '-fX' information in 
attempting to make sets. If you do not have single fish, its OK to leave this checked 
because if Flote can't find the string '-fX' then it will ignore this option. 
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For example, if you have eight groups: 'Con' and 'Exp', each containing 4 fish, then your 
group names will be 'Con_e00-f1', 'Con_e00-f2', 'Con_e00-f4' etc. By selecting this 
option, Flote will ignore the '-fX' so that you can easily define two sets 'Con' and 'Exp' 

10. 2. 2. 2. Smart Names 

When this is checked, Flote will attempt to guess the names of the sets. In doing so, it 
assumes that each group name begins with the string 'track_' and it will remove this string 
from the group names. 

Smart names is automatically turned off in several cases 
1. If you used the 'prefix' option when running the analysis, then the word 'track_' will not 
be present and Flote will turns smart names off 
2. If you are analyzing the summary.trk file or other data where the group name does not 
end in '-fX' (for fishwise analysis) or '_eXX', then Flote turns smart names off. 

This option can be a source of grief - if you find weird things happening, like groups 
being ignored, or datapoints lost, the first thing to try is turning this off. 'Smart names' is 
not so clever. 

10. 2. 2. 3. Ignore Case 

Self-explanatory 

10. 2. 2. 4. First +1 

Sometimes you want Flote to define sets, ignoring the first character in the string. An 
example: you analyzed the data according to quadrants, and now you have a 'Rsid_' group 
and a 'Lsid_' group. For the purpose of analyzing the rightward bias of turns, its desirable 
to analyze Rsid and Lsid separately, so you would define the groups as normal. But for 
the purpose of analyzing the turn-bias toward the target, or movement kinematics for 
side-oriented larvae, it is better to have the Rsid and Lsid measurements in the same set. 
So you can check the First+1 option and take the average of the Rsid and Lsid 
measurements. 

10. 2. 2. 5. Matching groups 

If you enter a string in the 'match' box, then only groups matching 
that string will be included in the sets. Others are simply ignored. 

10. 2. 3. Other ways to identify sets 
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The Define Sets menu has two special modes for defining sets. 

Sets can be defined 'manually'. Selecting this option brings up a window asking for a 
string to match 'Set 1' with. Any group which matches the text you enter here will be part 
of 'Set 1'. Continue entering strings that you want to match each set with. When you are 
finished, leave the box blank and hit 'OK'. This option also allows you to give the sets a 
name, by entering the match string, then a comma, then the name you want the set to 
have. For example entering 'a01a,First' will match all groups with the string 'a01a', and 
the set will be called 'First' (in the bar graph mode). 

Sets can be defined 'By position'. This is useful when larvae are in individual wells in a 
3x3 grid and were analyzed with the grid option. All the 'f1' larvae will be a set, the 'f2' 
larvae another set and so on. This is mostly intended to allow quick verification that 
position in the array is not influencing behavior. 

10. 3. Changing the Plot Window Format 

Right click inside the plot window to set the title of the window. To clear the title, right 
click and leave the box empty. 

To  change  the  color  scheme  use  the  controls  in  the  Format  menu.   You  can  individually  
set  the:  
Background  - color  of  the  blank  area  behind  the  plot  
Lines  - color  of  the  plot  axes  and  text  
Sets  - color  used  to  plot  the  value  of  all  the  sets   
Selected  - color  used  to  plot  the  value  of  the  selected  set  
Subset  - color  used  for  plotting  when  a  sub-range  of  values  has  been  specified.  

Six preset color schemes can be quickly specified. These are the options at the top of the 
Format menu. The schemes are described as Sets/Selected/Subset. Selecting 
White/White/White automatically turns on the 

Text size: The format menu also allows you to change the size of the font used 
(Format→Large Text or Small Text). The large text option is particularly useful when 
plots are being added to the printer output window in half size. The font can also be 
changed to a pseudo-Helvetica format for a chic Swiss look. 

Thick lines: The weight of the lines can be changed to a thicker appearance, using 
Format→Thick Lines, also mostly useful when plots are being added to the printer 
window in half size. 
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Outline bars: In graphs where the data appears as bars (histogram, bar graph, 
box/whiskers) selecting Format→Outline will circumscribe each bar with a black line (or 
whatever color you selected for Lines above). 

Grid: Horizontal grid lines can be added to the plot by selecting Format→Grid. 

Names vertical: In bar graph mode, if there are many bars, the names of the bars often do 
not fit underneath them. Names can be instead placed in a vertical direction on the left 
side of the bar by selecting Format→Names vertical. 

Error bars: In graph modes with error bars, the bars are plotted only upward by default. 
To have errors bars also stretching downward select Format→Bidir err. 

The size of the plot area can be changed by dragging the edges. To restore to the default, 
select Format→Restore. To grow or shrink the plot area by standard amounts select 
Format→Shrink or Enlarge. Similarly Show→Resize has some options for controlling 
size. 

Set the X and Y axes using Format→Set X-Axis and Format→Set Y-Axis. To restore 
the axes to automatically scaling, enter nothing in the dialog box. A shortcut to restore 
axes to auto-scaling is to click anywhere in the area to the left of the Y-axis. 

10. 4. Histogram Plots 

In histogram mode, datapoints are binned according to user-specified bin dimensions. 
The X-Axis shows each bin, displaying the high-value for datapoints in that bin. 

Set the bins of the histogram using the three boxes 'Min', 'Size' and 'Bins'. In addition, a 
first bin and a last bin will be automatically generated for datapoints lying outside the 
specified set of bins. 

Min  - the  highest  value  for  the  first  bin.   This  will  include  all  data  points  less  than  or  
equal  to  this  value.   For  example  if  set  to  10,  the  first  bin  will  include  all  data  points  less  
than  or  equal  to  10.  
Size  - the  width  of  each  bin  (except  for  the  first  and  last).   For  example  if  set  to  20,  then  
in  the  example  above,  the  second  bin  will  include  all  data  points  greater  than  10  and  less  
than  or  equal  to  30.  
Bins  - the  number  of  bins  between  the  first  and  last  bins.   Thus  if  this  is  set  to  10,  then  in  
the  above  example,  the  12th  bin  will  be  for  datapoints  greater  than  210.  

10. 4. 1. Selecting Bins 
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To select a group of bins, hold the left button and drag the mouse across the columns you 
want to be selected. To select everything less than a given bin, release the mouse button 
beside the left-hand Y-axis. To select everything greater than a given bin, release the 
mouse button beside the right-hand Y-axis. On the top right of the screen will be 
displayed 'where ...' indicating the subset selected. 

10. 4. 2. Comparing Sets 

By default, the distribution of a given set is superimposed on the overall distribution of 
all data points loaded. To examine a set in isolation uncheck the 'Background' checkbox. 

10. 4. 3. View Presets 

The four buttons on the left are available to set as preset views, including the parameter 
and bin setup. A keyboard shortcut for these buttons is available: press 1,2,3 or 4 to 
select the corresponding bit. 

To set the views use the Views menu - the selection will be set to match the current 
configuration. 

10. 5. Data points 

This plot shows the individual group values for each set, stacked vertically. Dots are 
randomly displaced in a horizontal direction to make it easier to see and avoid dots 
overlapping. Click in the graph to redistribute horizontal positions. 

10. 6. Bar Plots 

Bars are displayed in the order that the sets appear in the Sets droplist. To change this 
order, select a set and use the L and R buttons to move the set up and down (=left and 
right in the bar graph) in the droplist. 

10. 6. 1. T-tests between sets 

To compare all other sets to a selected sets, toggle ON the Show→T-test option. A 
shortcut is to double click on a bar - this will select that set, and toggle the t-test option 
on. Single click on another set to make it the comparison set. To clear the comparisons 
toggle OFF the Show→T-test option, or for a shortcut, click just to the right of the left Y-
axis. 
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To compare two sets, hold the left mouse button down above the first bar and drag across 
to the second bar then release the mouse button. You can do this multiple times. To 
clear the comparisons, hold the left mouse button while dragging the mouse from beside 
the left Y-axis to the right Y-axis. 

All t-tests are two-tailed and assume equal variances. 

By default, t-tests p values are directly given. However by toggling the Show→p values 
option, you can display symbols for different levels of significance. 

10. 6. 2. Single factor t-tests 

To compare the mean of a set to a specified value, select Show→One sample t. A dialog 
will open asking the numerical value for comparison. 

10. 6. 3. T-tests between parameters 

To compare the mean of a given parameter for a set, to the mean of another parameter for 
the same set, select a secondary parameter using the top right droplist. The two 
parameters will then be graphed side by side for each set. 

10. 6. 4. T-tests within parameter, different range 

This is accomplished by selecting a range of values for one parameter in histogram mode, 
then in bar graph mode, setting both the parameter and secondary parameter fields to be 
the same. 

Best explained with an example. You want to compare the duration of C-bends for left 
directed turns and right-directed turns. So you performed analysis with the 
Parameters→Rectify Neg Values option OFF. You open the summary.trk file and after 
eliminating datapoints and defining sets as usual, you do the following: 
1. In histogram mode, chose the Angle parameter 
2. Select the range of values less than zero by holding the left mouse button down slightly 
to the right of the left Y-axis, then dragging across to the side of the bar in the zero value. 
3. Go to the bar plot mode and chose the duration parameter - you should now have a 
simple bar plot showing the mean of the duration for each set. 
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4. In the top right corner, set the secondary parameter also to be 'duration' - the original 
bar will change size slightly because it now only shows the duration for angles greater 
than zero (and the n below each bar 
will only reflect the number of 
groups with angle greater than zero). 
In addition a new bar will appear 
beside it, showing the duration for 
angles less than zero. The label 
beside the right axis will reflect this. 
5. Select Show→T-test to get the p 
value of comparisons between bars. 

Note: for this to work properly you 
must use a 'standard size window' 
(Format->Restore). 

10. 7. Trend Plots 

10. 8. Bar Trend Plots 

10. 9. Box Plots 

The box marks the interquartile range (i.e. 25% to 75%) with the median as a black strip 
across the box. The whiskers represent the range of all points except for outliers, where 
outliers are points 1.5x the IQR below the first quartile, or above the third quartile. There 
is no current option to represent the outliers. 

To see what the values for the whiskers, interquartile range and median are, select 
Show→Average/SD. 

10. 10. Scatter Plot 

10.  11.  Circle  Plot  
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10. 12. Angular Plot 

The angular plot takes the groups and plots them as sectors on a circle, evenly distributed. 
This is most useful as a visual aid to comparing behavior analyzed using the 8 sector 
region of interest mode. The color of the bar indicates the value, with the scale bar in the 
right hand corner showing the range of colors and corresponding values. 

Use the Format→Thick Lines option to toggle the size of the bars. 

Use the Show→Average/SD option to toggle the name and value of the bars. 

Change the Y-axis scale to alter the color gradient. 

An advantage to using this method of analysis is that the 8 sectors now are visually 
displayed in the same orientation as the real world. 

10. 13. Saving Data 

The File menu offers several options for data output. There are two 
options for obtaining a copy of the graphical window: 

Save Image - save window as a tif file 

Copy Image - copy window to clipboard for pasting elsewhere 

There are additional options for saving tab separated text files of the 
data set. 

Save Data Set - save a tab separated (ie excel compatible) file with 
the current data loaded. This is an easy way to save data after 
deleting groups and data points. The file is found in the currently 
working folder, and has the same name as the currently loaded data 
set, with the string '_data' appended. 

Save Statistics - save the current mean, standard deviation (or SEM, 
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whichever you are currently showing) for all currently defined groups as well as the 
ANOVA between them. The file is found in the currently working folder, and has the 
same name as the currently loaded data set, with the string '_anova' appended. 

Save Means - first saves the mean of all groups into a new file appended with the string 
'_mean'. Then loads that file into memory. 

Save Hist Data - saves the histogram values for the current parameter examined and for 
the currently selected group. The output file is name of the current data file appended 
with the name of the selected parameter, and the selected group, then '_histdata' 

Save Percent - for each group, looks in the current parameter and counts the number of 
data points selected by the user, calculates what percentage of all values they constitute 
and saves the result in a new file named after the current working file, appended with the 
currently selected parameter and '_percent'. 

10. 14. Keyboard shortcuts 

1,2,3,4  -  set  view  

space  - clear  the  selected  group  
delete  - remove  the  selected  group  

a  - show a nova  
b  - bold  
m  - toggle  SEM/STD  
p  - toggle  paired  t-test  
t  - toggle  show t -test  
v  - toggle  vertical  name  plot  
y  - set  Y a xis  

z  - move  group  left  
x  - move  group  right  

,  - plot  previous  parameter  
.  - plot  next  parameter  
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11. Analyzing Data 

11. 1. Analyzing Movement Frequency 

11. 2. Analyzing Movement Directionality 

11. 3. Analyzing Movement Kinematics 

11. 3. 1. C-Bend and Counterbend Kinematics 

11. 3. 2. Swim Kinematics 

1.  Select  the  type  of  maneuver  whose  kinematics  you  wish  to  analyze  by  
checking  Behavior  →  [Select  scoot/burst/rturn  etc]  

2.  Remove  swim  bouts  with  zero  or  one  tailflip  - there  is  no  information  to  
analyze  in  these  swim  episodes  by  checking  Behavior→SwCycles  

3.  Select  the  kinematic  parameter  of  interest.   

Note, when analyzing the number of half swim cycles, it is important to 
remember that in instances where the fish was still swimming at the end of the 
recording, Flote designates the number of swim cycles as a negative number. 
There are two ways to deal with this: 
1. Enter histogram mode, and select only those swim cycle values >1 then click 
the /Sel/ button to remove all the incomplete swim cycles. 
2. Click the 'Abs' box on the left side of the menu area. This will convert all 
negative values into the positive value (eg, if the number of swim cycles is 
negative 5, it will become positive 5). 
In situations where there is a very large proportion of incomplete swim bouts 
(such as where you use a small recording window, or where the larvae are 
extremely hyperactive), neither method is ideal for analyzing the number of 
swim cycles and you should be careful to present the data as the number of 
swim cycles observed NOT the actual number of swim cycles the larvae 
executed. 
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12. Other Applications 

12. 1. Analyzing long time series data 

For tracking, Flote loads a series of frames into memory, then performs tracking, 
identifying all the larvae in the initial frame, designating each with an identifying number 
then tracking each larva across all frames loaded into memory. It is also possibly to track 
very long time series, without uniquely identifying the path of all the larvae in the 
recording. For example, you may have a 15 minute video, recorded at a low frame rate 
(for example 50 frames per second, so a total of 45000 frames), with larvae continuously 
entering and exiting from the recording field. To produce a picture of the paths made by 
the larvae during this recording, setup batch analysis to track 45000 events of 1 frame. 
The tracking directory will then contain 45000 tracking files. You can use the 
Tracking→Convert tracks to text function to convert the tracks to a series of tab-
separated text files containing the x,y positions of the larvae in each frame. Set the 
Tracking→Convert tracks to single text option so that all the tab-separated x,y positions 
are gathered into a single output file: C:\ftrack\alltracks.txt. 

Open this file with a plotting program and generate a scatter graph of the x,y coordinates. 
So long as your frame rate is fast enough, this should produce an image containing all the 
tracks of all the larvae entering or leaving the recording field over the 15 minutes. 

Note that if you have only a single larva in the testing arena, you can easily calculate 
information about the speed of movement using a spreadsheet. 

13. Troubleshooting 

I can't load files into Flote. 

Solution 1. Try turning on the 'File→Alphanumeric file order' option. If files now load 
ok, then your naming convention is not exactly what Flote is looking for. You can still 
operate Flote normally, but it will take longer to load each set of frames. 

Solution 2. There is a known bug where if you have certain windows open, the file load 
function fails. This often occurs if you have the zoom window or the time-series graph 
window open. So close these windows and try loading files again. 
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Tracking is very slow.
 
Make sure than 'Tracking→Rapid tracking' is turned on.
 

Too many heads are being found. 

1. Make sure the fish are the only contrast elements in the field 
2. Either reduce the size of the image so that the fish are of about the recommended size 
(ie about 50 pixels in length) 
3. Play with the head centroid finding controls as described in section 3.1 to fit your 
image. 
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